西海岸より

つらつらざつざつと

ruby

ruby実行時にLoadError

Mac環境で、Rubyでgemのライブラリを実行する際に、LoadErrorとなった時の対応。 結構はまった。。 sample.rb:4:in `require': no such file to load -- oauth (LoadError) from sample.rb:4 (原因1)gemで該当ライブラリがインストールされていない gemで必…

RubyによるTwitter投稿

Twitter APIをテストするための環境(Ruby)作りをした時のメモ。 環境 MacOSX 10.7 (Lion) Ruby 1.8系 oauthライブラリ デベロッパーキーの発行 twitterアカウントの取得 twitterデベロッパーサイトにアクセスしてログイン https://dev.twitter.com/ [Create …